Skip to main content
Loading
Version: Operator 3.3.0

Upgrade to 3.3.0

Operator versions starting from 2.0.0 can upgrade directly to versions 2.5.0 or earlier without going through the intermediate versions. See Upgrade to 2.5.0 for instructions and links to the correct files. The next version after 2.5.0 is 3.0.0.

For Operator versions 3.0.0 or later, the upgrade path is sequential through the intermediate versions. See Upgrade to 3.1.0 for instructions and links to the correct files.

You must start from Operator 3.1.0, then go through 3.2.2, to upgrade to 3.3.0. If you are on 3.2.0 or 3.2.1, you can upgrade directly to 3.3.0.

Choose the upgrade method based on your Operator installation.

Upgrade Operator on an OLM installation

Upgrade Operator on a Helm-based installation

Helm upgrades require manual user control. For Operator version 3.0.0 or later, you can perform a sequential upgrade through each intermediate version.