Skip to main content
Loading
Version: Operator 2.2.1

Release Notes

Bug fixes

  • [K0-120] - Handled long running init containers correctly without pod restarting
  • [KO-116] - Default fsGroup set as root group ID(0) in pod security context to grant init containers write permission to filesystem volumes in OpenShift

Known Issues

caution

OLM-based installations (OperatorHub.io and on Red Hat OpenShift) have a known issue with upgrading from version 2.2.0 to 2.2.1. This upgrade scenario revokes the RBAC privileges required to run Aerospike clusters in Kubernetes namespaces other than the aerospike namespace.

If you are upgrading from 2.2.0 to 2.2.1 and are running Aerospike clusters in Kubernetes namespaces other than the aerospike namespace, follow these instructions to restore the required RBAC privileges.